Resolved
A fix has been implemented. This issue is now resolved.
Identified
We have identified the underlying issue are currently implementing a fix.
Investigating
We're experiencing intermittent access issues to our manage portal and customer pages. We have identified the cause and are monitoring the incident.