SendGrid email notifications slowed and delayed
Resolved
Degraded performance

Our backend email service has processed all email notifications. Metrics have returned to normal.

Sat, Jul 20, 2024, 01:55 AM
5 months ago
Affected components
Notifications
Updates

Resolved

Our backend email service has processed all email notifications. Metrics have returned to normal.

Sat, Jul 20, 2024, 01:55 AM
20m earlier...

Monitoring

A configuration fix for our backend email service has been deployed. We will be monitoring metrics.

Sat, Jul 20, 2024, 01:35 AM

Identified

The root cause of the problem has been identified. A configuration fix for our backend email service is now in progress.

Sat, Jul 20, 2024, 01:34 AM
2h earlier...

Investigating

A problem with email notifications via SendGrid has been reported and confirmed. An escalation engineer has been paged and is actively investigating.

Fri, Jul 19, 2024, 11:02 PM