Management Portal and Public page outage
Incident Report for LaunchNotes
Resolved
This incident has been resolved
Posted Jan 13, 2023 - 17:05 PST
Investigating
We're currently experiencing an issue impacting access to the LaunchNotes management portal and public page. Notifications sent during this period may have been delayed
Posted Jan 13, 2023 - 16:50 PST
This incident affected: Published pages, Notifications, Management App, Embed applications, and API.